Project

General

Profile

Actions

Bug #5786

closed

Autojoin unreliable

Added by Myles D 7 months ago. Updated 7 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
11/18/2023
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 10
Regression:
No

Description

A server I'm on has a bot that auto-invites users to a channel once they're authenticated. This always happens right away when logging in. So I have an Autojoin set for that channel with a 5 second delay (which should be plenty). I know that this should work because I get the message that I'm invited to the channel, always within the same second as my authentication.

Most of the time it works - but sometimes, like 1 out of 8, it simply does nothing.

If there's a way to debug or troubleshoot I'm happy to help.

This is on the 64-bit 4.5 Beta from 29.10.2023. But I'm pretty sure it happened with 4.4 stable also.


Files

autojoin.png (8.87 KB) autojoin.png Myles D, 11/18/2023 05:58 PM
Actions #1

Updated by Myles D 7 months ago

To clarify, every time that it does not work, I still see the "Bot invites you to join #channel" message right after auth.

Actions #2

Updated by Per Amundsen 7 months ago

If you are talking about using the option "Join channels when invited", it does not use the delay option from the Serverlist, that option is only for auto joining channel on connect, to e.g give nickserv time to authenticate.

If you mean you are using a script with /sleep, please post the script.

You can monitor the invite message and any JOIN attempts in Menubar -> File -> Rawlog.

Actions #3

Updated by Myles D 7 months ago

I mean this, see attachment.
But this should be the appropriate one, no?

Will check Rawlog next time it happens.

Actions #4

Updated by Per Amundsen 7 months ago

This is not triggered by a invite, this is only triggered when you connect to the server.

Actions #5

Updated by Per Amundsen 7 months ago

Maybe I am misunderstanding, let's ee what Rawlog says.

Actions #6

Updated by Myles D 7 months ago

Yes, I know. The invite happens immediately since the Nickserv Identify happens right at connect, so having the general Serverlist Autojoin on a 5 sec delay would basically always work as it's always following the invite.

Actions #7

Updated by Per Amundsen 7 months ago

Ah okay, I see, yeah it should always work then.

Actions #8

Updated by Myles D 7 months ago

The only time I've been able to reproduce it, the bot invite actually took longer than those 5 seconds. If it's a laggy bot that would explain it. Let's close this and if anything genuine pops up I'll ping you again?

Sorry about the bother.

Actions #9

Updated by Per Amundsen 7 months ago

  • Status changed from New to Invalid

That does sounds more plausible, but yes let me know if you find a case where time is not the issue.

Also, depending on what type of message the bot invite is, you could use a script that performs the join for you, something like:

; if it's a private message, replace text to match as needed
on *:TEXT:*bot invites you to join #channel*:?:/join #channel

; if it's a private notice, replace text to match as needed
on *:NOTICE:*bot invites you to join #channel*:?:/join #channel
Actions

Also available in: Atom PDF