Project

General

Profile

Help plz

Added by Q Steinberg 2 months ago

I wanted to hear a beep when I receive a private message, and I managed to turn it on.
But now I hear a beep whenever I receive a new line in private message in an open window, which is disturbing.

How to fix that?


Replies (22)

RE: Help plz - Added by Q Steinberg 2 months ago

What I want is to turn off the beep I hear whenever I receive a new line in an active private chat.
Because the private window chat is already opened and I'm looking at it, so I don't need to hear a beep whenever i read a new line

I went to to Options - Sounds - On event - Open private window: No Sound

But it still beeps!

RE: Help plz - Added by Per Amundsen 2 months ago

There are two options in the dropdown, one called "Private Message" which plays a sound/beeps on every message and "Open Private Window" which only plays a sound/beeps on the first message received from that user.

RE: Help plz - Added by Q Steinberg 2 months ago

It's not working. And I tried to set "Open private Window" - No sound, but it still beeps.

This is so annoying and disturbing. Why would I hear a beep for every message I receive; while the window is already opened and I'm looking at it??!

RE: Help plz - Added by Per Amundsen 2 months ago

As I mentioned in my previous post, there are two separate items in the dropdown list, "Open Private Window" is the wrong one, you should change the one that says "Private Message", it's in the middle of the dropdown list, after "DCC Chat Message".

RE: Help plz - Added by Q Steinberg 2 months ago

If I change the one you are talking about "Private message" to No sound, then I won't hear a thing whenever I receive a private message.

So it's like, either I set it to "Beep", but then I will hear a sound whenever I receive a new line; even if the window is opened and active. Or, I set to "No sound" and hear nothing at all!!

RE: Help plz - Added by Per Amundsen 2 months ago

That is correct.

RE: Help plz - Added by Q Steinberg 2 months ago

And this is so annoying and disturbing. No other chat client or program would play a sound when I receive a new line in active window.

RE: Help plz - Added by Per Amundsen 2 months ago

Users have different preferences. You can use this script for now, press ALT + R to open the script editor and copy/paste the snippet below into it, then click the Save button.

on *:TEXT:*:?:if ($active != $target) { /beep 1 }

RE: Help plz - Added by Q Steinberg 2 months ago

I copied and saved it, and nothing has changed. Still facing the same problem

RE: Help plz - Added by Per Amundsen 2 months ago

You have to disable the "Private Message" sound option still, the script does the beeping now.

RE: Help plz - Added by Q Steinberg 2 months ago

It worked!

Thank you so much for your time and your effort.

AdiIrc is a perfect program. So it really makes me upset when I find a tiny option missing in it :)

Thanks again!

RE: Help plz - Added by Q Steinberg 2 months ago

Is there a snippet I could add to this one that you sent me to make it also beep when the private chat window is opened, but AdiIRC is minimized?

on :TEXT::?:if ($active != $target) { /beep 1 }

RE: Help plz - Added by Per Amundsen 2 months ago

Try this:

on *:TEXT:*:?:if (!$appactive) || ($active != $target) { /beep 1 }

RE: Help plz - Added by Q Steinberg 2 months ago

No, didn't work

RE: Help plz - Added by Per Amundsen 2 months ago

Make sure you have only one on TEXT event, e.g delete the other one, for reference it works for me.

RE: Help plz - Added by Q Steinberg 2 months ago

It doesn't beep when AdiIRC is minimized. Flashes only

Again, I mean when a private message was the last window active before minimizing AdiIRC

RE: Help plz - Added by Per Amundsen 2 months ago

Try replace your on TEXT script with this, when you receive a message while minimized, go to the private window, then copy paste the "Debug:" line to here.

on *:TEXT:*:?:{
  echo -g $target Debug: $appactive - $active - $muted - $ebeeps - $window(-2).state

  if (!$appactive) || ($active != $target) { 
    /beep 1 
  }
}

RE: Help plz - Added by Q Steinberg 2 months ago

Debug: $true - Dave - $false - $true - normal

RE: Help plz - Added by Per Amundsen 2 months ago

According to that debug line, adiirc was active and not minimized at that specific time.

RE: Help plz - Added by Q Steinberg 2 months ago

Debug: $true - zedd - $false - $true - minimized

RE: Help plz - Added by Per Amundsen 2 months ago

Okay, that one is interesting, it says adiirc is focused while simultaneously saying it's minimized, I am not sure how that is possible.

This should fix it (remove any other on TEXT):

on *:TEXT:*:?:if ($window(-2).state == minimized) || (!$appactive) || ($active != $target) { /beep 1 }

RE: Help plz - Added by Q Steinberg 2 months ago

Worked!

Thanks a lot for your time... I appreciate it

    (1-22/22)