Project

General

Profile

Notify option is not working properly

Added by Q Steinberg about 1 year ago

So my notify option is not working properly all the time. Sometimes it gives me a notification with sound that a user came online / or went offline, and many times it doesn't.

I went to options, and checked enable notify, added nicknames.
I'm also using the script that you once gave to me, a year ago or something.

When someone comes online:
on *:NOTIFY:{
if ($nick Zedd) /splay -q C:\Users\Lenovo\Desktop\yabadabado.wav
else if ($nick David) /splay -q C:\Users\Lenovo\Desktop\attention.wav

When someone goes offline:
on *:UNOTIFY:{
if ($nick Zedd) /splay C:\Users\Lenovo\Desktop\234526__foolboymedia__announcement-end.wav
else if ($nick David) /splay C:\Users\Lenovo\Desktop\234526__foolboymedia__announcement-end.wav


Replies (36)

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

Are you able to answer my question, about why when I add 4 nicknames, and the 4 of them are online, why does it only notify me on the 2nd and 3rd nicknames only?

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

And what I meant by "if I'm still alive" was that you asked me last year to wait for the new version, and promised it would solve the issues we had with the notify... and it didn't solve anything. Actually it was working better before the latest update.

So, I'm not sure whether I will be alive or not when it gets fixed

RE: Notify option is not working properly - Added by Per Amundsen about 1 year ago

Doubt that, not sure how I could have promised to fix a issue I just learned about an hour ago.

Anyways, the reason why you get inconsistent notify sounds, is because on NOTIFY doesn't always trigger when it should, if it doesn't trigger your script doesn't run and it doesn't play sound, which is what I fixed for next beta.

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

Thank you for your time and for your effort. Wish you a good day

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

By the way, it doesn't play a sound, as you mentioned, and it also doesn't notify my through a message that the 1st and 4th nicknames are online. It doesn't show their nicknames on the treebar either

RE: Notify option is not working properly - Added by Per Amundsen about 1 year ago

I am not able to reproduce that, you can check what the server tells you about these nicks in Menubar -> File -> Rawlog.

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

Rawlog shows them joining and leaving the room

So it's pretty clear that the notify system capacity on adiirc is only capable of showing two nicknames on the Treebar. And it doesn't include the first nickname that was added in the script

on *:NOTIFY:{
  if ($nick == FirstNickname) /splay -q directory.wav

Hope it would get fixed in the next version. And again, thank you for your time and your effort.

RE: Notify option is not working properly - Added by Per Amundsen about 1 year ago

This is not true, I have 20 notify nicks in my Treebar.

Adiirc supports 3 different notify systems based on what the server offers.

You can use Rawlog to see the messages related to the servers notify system, look for messages containing "600" (logged online), "601" (logged offline), "604" (is online), "605" (is offline) and the nicks, joins/parts are not relevant here.

The librairc server uses the WATCH system, so also look for "WATCH" messages containing nicks, you should be able to determine if the users in your notify list are properly watched and whether the server properly sends online/offline rawlog messages.

In the past, users have had problems with notify when using a ZNC server, there is some sort of bug in ZNC which happens in all clients, they fixed it by disconnecting/reconnecting the ZNC server.

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

Ok. So I tried changing the server, and it worked, as you said.

Then I changed the server and went back to the one I always use, and it's now working perfectly!

So all I had to do was to change servers, and re-enter the server I use? I don't know. I guess it doesn't matter now :) All it matters is it's FINALLY working

RE: Notify option is not working properly - Added by Q Steinberg about 1 year ago

As I mentioned before, everything is working perfectly. But is there a way to make the "notify sound" work when I am active on adiirc?
As it only plays a notification sound when adiirc is minimized

RE: Notify option is not working properly - Added by Per Amundsen about 1 year ago

That is the bug I fixed and is in the next beta.

(26-36/36)