Project

General

Profile

Help

Added by Q Steinberg about 1 year ago

I just installedAdiIRC's new version, and I would like to know how to disable the beep sound when I'm already in an active private chat window. I only want it to beep when AdiIRC is minimized or when the private chat window is not active. Thank you


Replies (7)

RE: Help - Added by Q Steinberg about 1 year ago

I still hear that beep sound when I receive a message in an active private window.

I went to Options - Sounds - and I unchecked 'Play message sounds in active window. and in Event, Open private window - No sound.

Yet it still makes a beep. So how can I stop it?

RE: Help - Added by Per Amundsen about 1 year ago

When you receive a new message in a private window, a sound is only played if "Options -> Sounds -> on Event -> Private message" is set to "Beep" or "Play sound" and "Enable sounds" are enabled, and "Temporary mute sounds" is not enabled.

If AdiIRC is the active desktop window, the "Only play sounds if AdiIRC is not focused" is considered.

If the current active channel/private window is the target window, the "Play message sounds in active window" is considered.

The last ways to play a sound is by having a broken "Options -> Highlights" rule that is set to play a sound or by a script using the /beep or /splay commands, so maybe check if you have such a script.

RE: Help - Added by Per Amundsen about 1 year ago

One other way it can play sounds, if you have "Options -> Sounds -> on Event -> Buffer" set to "Beep" or "Play sound" and you receive a new message while being scrolled up in the text area buffer.

RE: Help - Added by Q Steinberg about 1 year ago

As I mentioned before, my problem is hearing a beep sound when I receive a new message line in an active, opened private window. And this is what I want to stop.

I found this script in my AdiIRC. I think it's an old script that I used to stop the beep sound. I wonder if removing it would solve the problem?

on *:TEXT:*:?:if ($window(-2).state == minimized) || (!$appactive) || ($active != $target) { /beep 1 }

RE: Help - Added by Per Amundsen about 1 year ago

This script does the opposite of stopping beeps, could be the source of your issue.

RE: Help - Added by Q Steinberg about 1 year ago

Fixed. Thx

    (1-7/7)