Project

General

Profile

Bug #3272

/did -e when 'disable' option set in dialogs

Added by westor (GR) almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
02/04/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

It seems that the /did -e doesn't work into 'list' item when there is the 'disable' option set in the dialog setup options because after the dialog became in normal state the /did -e it doesn't seems to work under the "INIT" on dialog event, i will provide an short reproduce code to see.

Also when the dialog is in opening progress and i have set or in the dialog setup the 'disable' option or into any id the 'disable' option it should be opening the dialog or the id as disabled, as it doesn't now.

Test code:

dialog testing {
  title "test" 
  size -1 -1 107 108
  option dbu disable
  list 3, 4 30 99 47, size vsbar disable
}

ON *:DIALOG:testing:*:*: {
  if ($devent == init) {
    did -a $dname 3 Test data
    did -e $dname 3
  }
}

- Thanks!

#1

Updated by Per Amundsen almost 3 years ago

  • Status changed from New to Resolved

Fixed for next beta.

#2

Updated by Per Amundsen almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF