Project

General

Profile

Feature #3550

AWAY: Add checkbox option to auto come BACK(all networks) when the mouse is moved

Added by R S 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
07/07/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All

Description

Currently, there is a bug in the 'Automatically set back when typing' feature. But if it was working, I would still like to request a new 'Automatically set back when mouse moves' feaure. Ideally(or make this a checkbox as well), I would like this to detect mouse movement anywhere on the pc. So, if I'm in Outlook or working on spreadsheets, I would not expect Adi to put me in AWAY status...it's just that Adi doesn't have focus at that time but I am active on the pc. This is how Discord/ICQ/Facebook chat, etc etc etc all work. If you move the mouse or use the keyboard(anywhere on the pc), it sets your status to online/active unless you disable that.

Related to this, I would like it to come back on all networks. Currently, the auto BACK feature only seems to work for the single network you're typing into. I opened a separate issue about this a few minutes ago.

Thanks

History

#1

Updated by westor (GR) 5 months ago

Also including the "Automatically set back when pressing any mouse buttons" either.

#2

Updated by Per Amundsen 5 months ago

  • Category set to Interface
  • Status changed from New to Rejected
  • Assignee set to Per Amundsen

Away works on a per server basis.

"Automatically set away" works by checking how long since you last sent a message to a server on each server individually.

"Automatically set back when typing" works as designed, it eets you back when sending a message on that specific network, the text might be misleading/confusing, I'll fix the text.

I have no plans adding checks for keyboard typing or mouse activity, it's a simple away system.

I'll think about adding a option to use global away and back.

Also available in: Atom PDF