Project

General

Profile

Actions

Bug #3619

closed

/reload -rs FILE it should strip the case sensitive

Added by westor (GR) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
07/24/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is an bug, if i am trying to /reload (i am not sure if it is effected by /load or /unload too.) an script file by using case sensitive characters it doesn't strips them out and loading the same file again as it shouldn't.

Example:

/reload -rs test.mrc = it will load the 'test.mrc' file correctly.
/reload -rs TeSt.mrc = it will load the 'TeSt.mrc' file instead of 'test.mrc' file, so it's error.

- Thanks!

Actions #1

Updated by Per Amundsen over 5 years ago

Seems to work fine with any casing, maybe you have the wrong path?

Actions #2

Updated by westor (GR) over 5 years ago

Ah sorry incorrect example:

/reload -rs test.mrc = it will load the 'test.mrc' file correctly.
/reload -rs1 TeSt.mrc = it will load the 'TeSt.mrc' file instead of 'test.mrc' file, so it's error.

This occurred if N is specified to be placed in an exactly script editor order.

Actions #3

Updated by Per Amundsen over 5 years ago

This also works as expected, test and teSt is the same file.

Actions #4

Updated by westor (GR) over 5 years ago

Actions #5

Updated by Per Amundsen over 5 years ago

Okay I see, this might be related to your windows locale, which I guess is Greek, I'll see if I can replicate in a virtual machine with Greek locale.

Actions #6

Updated by Per Amundsen over 5 years ago

I was unable to reproduce this even with Greek locale.

Actions #7

Updated by westor (GR) over 5 years ago

I've created an clean adiirc 64 bits, i took a video about how-to reproduce it if that doesn't also helps, then tell me to find an other way.

Video: http://a.pomf.cat/apgysr.mp4

Actions #8

Updated by Per Amundsen over 5 years ago

  • Status changed from New to Resolved

Okay I figured it out, was not related to file names, the case-insensitive list that holds the filenames had a bug, where it searches for the item case-insensitive, but deleted it case-sensitive in some cases.

Actions #9

Updated by Per Amundsen over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF