Project

General

Profile

Bug #3930

Beeing disconnected from ZNC server for "no reason"

Added by Leonel Faria about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
06/06/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 10
Regression:
Yes

Description

Hello, I use AdiIRC with ZNC and have been using it like this since the beggining with no issues, but since last update (can't confirm if it is related) I have been getting this message on the status window:
* Caps set: account-notify away-notify batch extended-join multi-prefix server-time userhost-in-names znc.in/server-time-iso

I've never seen that message before only after the last update (to version 3.1 Beta Build 2018/05/27 64 Bit) and then I get disconnected from my ZNC without any aditional message.

But the strange is that sometimes I don't get disconnected at all and I simply press Connect button and get connected ans stays connected...

History

#1

Updated by Per Amundsen about 1 year ago

What version are you using exactly? Oops I noticed it now.

Caps have been in use for many years, but it was not always displayed in the status window.

For any type of connection issue it's best to debug using the Rawlog window, go to file -> Rawlog, then start your connections, when it fails, go back to rawlog, then check the "Debug", there should be clues there.

#2

Updated by Leonel Faria about 1 year ago

Per Amundsen wrote:

What version are you using exactly? Oops I noticed it now.

Caps have been in use for many years, but it was not always displayed in the status window.

For any type of connection issue it's best to debug using the Rawlog window, go to file -> Rawlog, then start your connections, when it fails, go back to rawlog, then check the "Debug", there should be clues there.

I have turned on the rawlog and restarted the AdiIRC and got this on the Debug page:


-> 06-06-2018 08:30:49 - mydomain.com - ConnectThread Stop() called
-> 06-06-2018 08:30:49 - mydomain.com - ReadThread Stop() called
-> 06-06-2018 08:30:49 - mydomain.com - WriteThread Stop() called
-> 06-06-2018 08:30:49 - mydomain.com - PingThread Stop() called
-> 06-06-2018 08:30:49 - mydomain.com - Disconnect step3 done
-> 06-06-2018 08:30:49 - mydomain.com - SocketRead error: Não é possível aceder a um objecto eliminado.Nome do objecto: 'SslStream'.
-> 06-06-2018 08:30:49 - mydomain.com - Disconnect step4 done
-> 06-06-2018 08:30:49 - mydomain.com - isreconnect = false, exiting

I have just replaced my domain for a dummy one, about the SocketRead error translated to english says "It wasn't possible to access a deleted object. Name of the object 'SslStream'

Does this gives you any lights on the issue?

#3

Updated by Per Amundsen about 1 year ago

I feel like there are some crucial lines missing, could you post some more lines from the log? preferably from the start of the connection attempt.

If worried about privacy, you can email to to me at

#4

Updated by Leonel Faria about 1 year ago

Per Amundsen wrote:

I feel like there are some crucial lines missing, could you post some more lines from the log? preferably from the start of the connection attempt.

If worried about privacy, you can email to to me at

I have sent you and email with two rawlogs.

Maybe its related to:

System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) em System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add) em AdiIRC.IRC.Core.SafeDictionary`2.Add(TKeyT key, TValueT val) em AdiIRC.IRC.Core.IrcCore.ReadLine(Object sender, ReadLineEventArgs e)

#5

Updated by Per Amundsen about 1 year ago

There is an error here during CAP ls, not sure yet if that can cause a connection issue, but I will see if I can replicate what's going on.

These 3 lines are from the same CAP LS error, stack trace / error / raw line.

-> 06-06-2018 08:48:26 - server -    em System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)   em System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)   em AdiIRC.IRC.Core.SafeDictionary`2.Add(TKeyT key, TValueT val)   em AdiIRC.IRC.Core.IrcCore.ReadLine(Object sender, ReadLineEventArgs e)

-> 06-06-2018 08:48:26 - server - Um item com a mesma chave já foi adicionado.

-> 06-06-2018 08:48:26 - server - :irc.znc.in CAP unknown-nick LS :batch cap-notify echo-message multi-prefix server-time userhost-in-names znc.in/batch znc.in/self-message znc.in/server-time-iso
#6

Updated by Leonel Faria about 1 year ago

One strange thing that I don't know if it is related, on the 3.1 Beta we get 4x times the same line eg.

-> 06-06-2018 09:30:04 - mydomain.com - YOU ARE 100% CONNECTED
-> 06-06-2018 09:30:04 - mydomain.com - YOU ARE 100% CONNECTED
-> 06-06-2018 09:30:04 - mydomain.com - YOU ARE 100% CONNECTED
-> 06-06-2018 09:30:04 - mydomain.com - YOU ARE 100% CONNECTED

But I am only connecting to two networks, I tried on the 3.0 Portable version and not only I dont get the issue but also I only see 2x lines as expected.

#7

Updated by Per Amundsen about 1 year ago

Oh that is really interesting, It's possible that each server is trying to connect to the same server twice, would explain the weird error as well.

How are you connecting, e.g autoconnect servers in the serverlist or through the /server command or manually?

#8

Updated by Leonel Faria about 1 year ago

Per Amundsen wrote:

Oh that is really interesting, It's possible that each server is trying to connect to the same server twice, would explain the weird error as well.

How are you connecting, e.g autoconnect servers in the serverlist or through the /server command or manually?

Auto connect from server list

#9

Updated by Per Amundsen about 1 year ago

I see, you are using the old Serverlist, I did not test that with some recent auto connect servers changes since it's deprecated for many years, I'll look into it.

#10

Updated by Leonel Faria about 1 year ago

Per Amundsen wrote:

I see, you are using the old Serverlist, I did not test that with some recent auto connect servers changes since it's deprecated for many years, I'll look into it.

Old server list? Is there a new?

I can use the new, how do I get it?

#11

Updated by Per Amundsen about 1 year ago

Options -> Servers -> Use new server list

#12

Updated by Per Amundsen about 1 year ago

  • Status changed from New to Resolved
  • Regression changed from No to Yes

I found and fixed this issue for next beta, thanks.

#13

Updated by Per Amundsen about 1 year ago

  • Status changed from Resolved to Closed
#14

Updated by Leonel Faria about 1 year ago

Per Amundsen wrote:

I found and fixed this issue for next beta, thanks.

Nice :)

I believe that with the "New Serverlist" there is no issue, I am using it now :P

#15

Updated by Per Amundsen about 1 year ago

Excellent :)

Also available in: Atom PDF