Project

General

Profile

Bug #4027

Channel Editor scroll and display issues

Added by westor (GR) 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
07/13/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There are some couple of issues related the Channel Editor.

1): When opening the channel editor the last item on listbox doesn't displayed correctly.

2): When mouse cursor is into the listbox then Up scroll doesn't working at all, i try to move scroll up but halting out, seems only scroll Down working.

3): According to the new feature addition #4000 it seems when you move the scrollbar at the right end then it displays incorrect the listbox items

Examples images:

1):

3):

- Thanks!

2018-07-13_10-24-09.mp4 (1.19 MB) 2018-07-13_10-24-09.mp4 westor (GR), 07/13/2018 09:26 AM
2018-07-13_10-38-08.mp4 (1.57 MB) 2018-07-13_10-38-08.mp4 westor (GR), 07/13/2018 09:39 AM
2018-07-13_21-04-47.mp4 (4.56 MB) 2018-07-13_21-04-47.mp4 westor (GR), 07/13/2018 08:46 PM

History

#1

Updated by westor (GR) 3 months ago

Also i reproduced three more issues after report.

1): When you have Channel Editor open and someone changes b,e,I (q not tested) channel modes then it doesn't sorting them as it should #4015 bug report fixed that, it also trigger and some times when the Channel Editor is not opened.

Example Code:

//var %i 1 | while (%i <= 30) { mode # +b test_ $+ %i | inc %I } | ban -u111211111 $me

Example Video: http://j.mp/2up83M2


2): When you CTRL + Single click seperate items and then trying to scroll down and CTRL + Single click select more items it unset previously selected items.

Check this video to reproduce it: http://j.mp/2zK8c2L

#2

Updated by Per Amundsen 3 months ago

1): When opening the channel editor the last item on listbox doesn't displayed correctly.

I have not been able to reproduce this.

2): When mouse cursor is into the listbox then Up scroll doesn't working at all, i try to move scroll up but halting out, seems only scroll Down working.

I fixed that.

3): According to the new feature addition #4000 it seems when you move the scrollbar at the right end then it displays incorrect the listbox items

I have not been able to reproduce this.

1): When you have Channel Editor open and someone changes b,e,I (q not tested) channel modes then it doesn't sorting them as it should #4015 bug report fixed that, it also trigger and some times when the Channel Editor is not opened.

The sorting is correct, you have the sorting set to oldest first in the video. (arrow downward)

2): When you CTRL + Single click seperate items and then trying to scroll down and CTRL + Single click select more items it unset previously selected items.

This because of the mouse move to select item feature, it seems very sensitive, I don't have a solution atm.

#3

Updated by Per Amundsen 3 months ago

1): When opening the channel editor the last item on listbox doesn't displayed correctly.

Possibly fixed, but not able to reproduce so can't confirm, also it's not a listbox, it's a custom datagrid.

#4

Updated by westor (GR) 3 months ago

There is also a new bug related to Channel Editor, when double click on an item and pressing Save without changing anything it removes a random item from the list and setting a mode on the channel, check this video to reproduce http://j.mp/2mhye3M

Check that attached video to reproduce 1+3 and everything else above reported.

#6

Updated by Per Amundsen 3 months ago

It is sorting correctly in that video, since they were all added at the same time, they all have the same timestamp.

I don't know why the icon is not drawing correctly for you.

#7

Updated by Per Amundsen 3 months ago

To summaries.

1): When opening the channel editor the last item on listbox doesn't displayed correctly.

Unable to reproduce, possibly fixed.

2): When mouse cursor is into the listbox then Up scroll doesn't working at all, i try to move scroll up but halting out, seems only scroll Down working.

Fixed.

3): According to the new feature addition #4000 it seems when you move the scrollbar at the right end then it displays incorrect the listbox items

Unable to reproduce, this might depend on the size of the datagrid, the size of column and the size of the text.

4): When you have Channel Editor open and someone changes b,e,I (q not tested) channel modes then it doesn't sorting them as it should #4015 bug report fixed that, it also trigger and some times when the Channel Editor is not opened.

Calling this 4 now, not a bug, sorting works correctly.

5): When you CTRL + Single click seperate items and then trying to scroll down and CTRL + Single click select more items it unset previously selected items.

Calling this 5 now, I don't have a solution.

6): Sort arrow is not drawn correctly.

Not able to reproduce so far.

Please use the correct number for referring to these issues and use a new number for any new issues.

#8

Updated by Per Amundsen 3 months ago

Forgot one.

7): Clicking save during a edit causes the ban to be removed.

Reproduced, no fix yet.

#9

Updated by Per Amundsen 3 months ago

7 is fixed.

#10

Updated by westor (GR) 3 months ago

Thanks for response and sorry for confusing you with the order, if you have an recent build uploaded tell me to give a try and report you back the problems (if they).

#11

Updated by Per Amundsen 2 months ago

How is issue 1, 2, 3, 6, 7 in this build https://adiirc.com/build/AdiIRC64.exe?

The changes also effects Monitor Panels, Channel List and Logs Manager.

#12

Updated by westor (GR) 2 months ago

Seems to be fixed for now i didn't saw them again to be triggered, if i will see something i will report it in a new bug report.

- Thanks!

#13

Updated by westor (GR) 2 months ago

There is an issue related on that latest unofficial build you gave me to test, when i add an ban the date+time value on list is incorrect.

(10/Aug/2018 00:28:56) ● #Test_Chan egagaegegae!*@* set by westor (Fri Aug 10 00:24:42 2018)
(10/Aug/2018 00:28:56) ● #Test_Chan End of Channel Ban List
#14

Updated by westor (GR) 2 months ago

Also there is one more issue related to the fix on #4035 , if you do several times /mode #channel b and then open the channel editor then you are gonna see mutiple same items on the list.

#15

Updated by Per Amundsen about 2 months ago

8) There is an issue related on that latest unofficial build you gave me to test, when i add an ban the date+time value on list is incorrect.

I have not been able to reproduce this.

10) Also there is one more issue related to the fix on #4035 , if you do several times /mode #channel b and then open the channel editor then you are gonna see mutiple same items on the list.

This should be fixed now.

I added the number 9 and 10 for these new issues, please add numbers for new issues or this is gonna be impossible to follow.

#16

Updated by Per Amundsen about 2 months ago

5) was also fixed.

#17

Updated by Per Amundsen about 2 months ago

  • Status changed from New to Resolved
#18

Updated by Per Amundsen about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF