Project

General

Profile

Actions

Bug #5433

closed

Channel list "Get list" button is not disabled on server error in some cases

Added by eahm eahm 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
11/08/2021
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

If we have to change parameters before clicking "get list" again the server may answer with "busy command" or "try again later" and the "get list" button will not be clickable again until we send the /list command again, which may result in an endless loop of busy results if we still have to change some parameters.

Can we have the get list button reset itself every 10-20 seconds?

Thanks.

Actions #1

Updated by Per Amundsen 7 months ago

  • Category set to Interface
  • Status changed from New to Assigned

Can you provide the raw messages from the Rawlog Dialog which contains the "busy command" or "try again later" messages?

They should be resetting the buttons.

Actions #2

Updated by eahm eahm 7 months ago

Well, I don't know what happened but now if I want to change the min number of users and click "Get List" again for example it's not grayed out anymore, it works as expected.

The "LIST Server load is temporarily too heavy. Please wait a while and try again." is not an AdiIRC issue anyway, it's a server antiflood /list service. I tried to flood it and now AdiIRC returns the cliclable "Get List" even when the server gives has that protection activated.

I guess we can say there is nothing to be fixed for now and you can close this, I will let you know if I come across that issue again.

Actions #3

Updated by Per Amundsen 7 months ago

I know it's an server error, but all server errors have a specific numeric attached to it that adiirc uses to determine what the error means.

There might be servers using a error code adiirc currently doesn't know about, so please copy the message from Rawlog if it happens again.

Actions #4

Updated by eahm eahm 7 months ago

<- 1/27/2022 14:36:45 - @time=2022-01-27T21:36:48.449Z :irc.efnet.nl 263 NICK LIST :Server load is temporarily too heavy. Please wait a while and try again.

This one?

Actions #5

Updated by Per Amundsen 7 months ago

Yes, I added support for this for next beta, hopefully that fixes it.

Actions #6

Updated by eahm eahm 7 months ago

Would you like me to try other EFnet servers or that code number is default by the whole network?

Actions #7

Updated by Per Amundsen 7 months ago

It would most likely be the same on all servers on the same network since they would be using the same software.

Actions #8

Updated by eahm eahm 7 months ago

Yep, another server gives 263. Thanks for checking all this stuff man.

Actions #9

Updated by eahm eahm 7 months ago

But IMO this can be closed too since I see the "Get List" every time now and it's not grayed out anymore.

Actions #10

Updated by Per Amundsen 7 months ago

  • Category changed from Interface to Irc
  • Status changed from Assigned to Resolved
Actions #11

Updated by Per Amundsen 7 months ago

  • Status changed from Resolved to Closed
Actions #12

Updated by Per Amundsen 7 months ago

  • Tracker changed from Feature to Bug
  • Subject changed from /list dialog "issue" to Channel list "Get list" button is not disabled on server error in some cases
  • Category changed from Irc to Interface
  • Regression set to No
Actions

Also available in: Atom PDF