Project

General

Profile

Actions

Bug #5515

closed

/window -jN should use max value for overflowing values

Added by westor (GR) 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
03/28/2022
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I was testing to /loadbuf a file into a @window with more than 165k of lines, it seems that AdiIRC when creating a /window -jN it sticks on 500 and ignores the N parameter for larger windows buffer.

Example:

//window -hj100000000000 @test
//loadbuf @test big_file.txt
//echo -a IS: $line(@test,0) == this will return 500 even if the big_file.txt has more than 500 lines.

- Thanks!

Actions #1

Updated by westor (GR) 3 months ago

An other reproduce code that may help you more is: https://mypastebin.com/FVCfN6MXi

Actions #2

Updated by Per Amundsen 3 months ago

  • Subject changed from /window -jN does not working to /window -jN should use max value for overflowing values
  • Status changed from New to Resolved

The number you enter are too large, the max value is 2147483647.

I made a check to use the max value if the entered number is larger.

Actions #3

Updated by Per Amundsen 3 months ago

  • Status changed from Resolved to Closed
Actions #4

Updated by westor (GR) 3 months ago

Thanks for applying that fix, if it is possible to mention under https://dev.adiirc.com/projects/adiirc/wiki/window page that -jN has 2147483647 limitation to remember the maximum.

Actions #5

Updated by Per Amundsen 3 months ago

2147483647 is the maximum for a integer, it is not the maximum for number of lines.

Documenting a maximum number gives the impression that it is possible and supported to reach such a high number.

It is not realistic to reach such high number of lines since maximum number of lines involves many dynamic factors such as how much memory is available, whether using 32 or 64 bit, limitations of .net internals such as maximum size of a list and so on.

Actions

Also available in: Atom PDF