Project

General

Profile

Bug #4891

closed

bug menu on several open pm

Added by armin armin almost 2 years ago. Updated almost 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
01/22/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hi,

reproduce the bug:

1) Open 1 PM for example.

2) Right click on the PM (sidebar tab) but not on the nickname but more left in the white space, the right click menu is not the same as if you right click on the nickname.

This is a big user experience problem (UX)

I would have liked to create a personalized AdiIRC for example by naming it <name_enterprise>'Script using AdiIRC but I can not I find that there are about 5-8 bugs already identified, here is the summary "quick:

1) (strict) Problem of disconnection from time to time, there could be a disconnection of the server with AdiIRC if we barely have 50kb / s or 100kb / s of Internet connection or something like that (https://dev.adiirc.com/issues/4883)

2) (minor) add button "Edit" instead of "Add" : https://dev.adiirc.com/issues/4879

3) (maybe resolved) (strict) Problem icon of driver "Lav Audio" with sound of AdiIRC : https://dev.adiirc.com/issues/4873

4) (strict) Problem icon of driver "Lav Audio" with sound of AdiIRC : https://dev.adiirc.com/issues/4873

5) Severe problem of /cnick in mass that freezes the windows of AdiIRC for a while (loading time), AdiIRC should do all of this in asynchrome, ie while it loads we can use the windows !!

6) Problem conflict ctcp with spamfilter of unrealircd 5 : https://dev.adiirc.com/issues/4890

The problems solved:
- Since using the beta version, there is no data loss in config.ini which made AdiIRC blank

#1

Updated by Per Amundsen almost 2 years ago

  • Category set to Interface
  • Status changed from New to Invalid
  • Assignee set to Per Amundsen

This is by design and the same as mirc, clicking the text shows the window menu, clicking outside the text shows thre Treebar menu.

There is an option to use full width right-click menu at https://dev.adiirc.com/projects/adiirc/wiki/Treebar_Options#Use-full-width-right-click

#2

Updated by armin armin almost 2 years ago

no no you didn't understand, I explain with pictures:

1) Open new PM

2) Click on green dot (pseudo part) : the "close" menu is ok

3) Click on the white part here or here (in green) the "close" menu is not visible. if we click on the "blue" point it's ok. It would have been good to put this same menu for the 3 points

#3

Updated by Per Amundsen almost 2 years ago

I do understand, see my previous post on how to archive what you want.

Also available in: Atom PDF